Age of Empires II - Gold Eidtion - Win 7 - Won't start

  • Christian Chat is a moderated online Christian community allowing Christians around the world to fellowship with each other in real time chat via webcam, voice, and text, with the Christian Chat app. You can also start or participate in a Bible-based discussion here in the Christian Chat Forums, where members can also share with each other their own videos, pictures, or favorite Christian music.

    If you are a Christian and need encouragement and fellowship, we're here for you! If you are not a Christian but interested in knowing more about Jesus our Lord, you're also welcome! Want to know what the Bible says, and how you can apply it to your life? Join us!

    To make new Christian friends now around the world, click here to join Christian Chat.
W

wwjd_kilden

Guest
#1
When I try to start the game, the screen flickers, the settings change (because I altered them in the properties),
it then flickers again and goes back to the way it was. No sign of the game starting.

I've googled it of course:
Some people say it is not compatible with Win 7 and just won't work
but a lot of people seem to be able to play it without any other problems than colour issues.

After asking both Google and Adison:

I've tried two different patches (but they seem to be mostly about fixing colour issues)

I've tried running it in compatibility mode (Win XP, Win 95)

I've tried running it with different resolution / colour settings

I've tried the -nostartup code to skip the intro

and a combination of those

----
Nothing works! It doesn't get to the point where it starts starting :p


- Anyone know what else I can try?

Is there any difference between using the compatibility mode and running something in an emulator?
If there is, are there any safe, free ones I can use?
 

Ugly

Senior Member
Apr 19, 2011
20,651
630
113
#2
In my experience that's a compatibility issue. Only a few tricks can make them continue to work, but its often just a stall.
I've lost a few games, over the years, to these issues.
Not sure that emulators will work. Not positive though.
 
Jul 15, 2017
34
1
8
#3
Can't help you with your issue (sorry) just thought I would comment when I saw age of empires II haven't played that game in a very long time used to absolutely love it though :cool:
 
S

Sully

Guest
#4
Maybe look into the Application Event Viewer for an entry? Might lead to something.
 
C

CaptainGoat

Guest
#5
Brother wanted that game and he asked my mum to buy it for a birthday present. She went in and asked for "Aid To Vampires" which no one in the shop had heard of.
 

Milktalk

Senior Member
Feb 19, 2017
551
22
18
#6
wwjd_kilden hi ww ol pal: just a btw u can buy Age of Empires 2 HD edition off steam! I'm thinking of getting it sometime :)
 

G00WZ

Senior Member
May 16, 2014
620
29
28
#7
I think i posted something about this earlier but you might need to download Dosbox to run it
 
W

wwjd_kilden

Guest
#8
Maybe look into the Application Event Viewer for an entry? Might lead to something.
where do I find that?
(For having an IT education I know very little stuff that is useful to myself :p )
 
W

wwjd_kilden

Guest
#9
wwjd_kilden hi ww ol pal: just a btw u can buy Age of Empires 2 HD edition off steam! I'm thinking of getting it sometime :)
I know, but that would mean I've bought it twice. I think it's unfair of Microsoft not to make us able to keep playing the one we already bought :p
 
W

wwjd_kilden

Guest
#10
I think i posted something about this earlier but you might need to download Dosbox to run it
Reading about it now
but AoE isn't a DOS game, so would it help? Would I have to "install" an old version of Windows within the DOSbox environment?
 
S

Sully

Guest
#11
where do I find that?
(For having an IT education I know very little stuff that is useful to myself :p )
Right click "my computer" and you'll see "computer management" click that and you'll see event viewer, open that and you should find "application" if you recreate the error note the time and then refresh the application events and see what occurred at that time.
 
W

wwjd_kilden

Guest
#12
Ooooo! Neat. I definitely have to remember that one.

my OS is in Norwegian since I try to help my parents now and then, but,
what it tells me is basically:

Wrong process ID
Wrong start time
Wrong program path
Wrong module path


...
Programnavn med feil: EMPIRES2.EXE, versjon: 0.14.22.712, tidsangivelse: 0x39660360
Modulnavn med feil: EMPIRES2.EXE, versjon: 0.14.22.712, tidsangivelse: 0x39660360
Unntakskode: 0xc0000005
Feilforskyvning: 0x0000e415
Feil prosess-ID: 0xb50
Feil starttid for program: 0x01d3088514573d13
Feil programbane: C:\Program Files (x86)\Microsoft Games\Age of Empires II\EMPIRES2.EXE
Feil modulbane: C:\Program Files (x86)\Microsoft Games\Age of Empires II\EMPIRES2.EXE
Rapport-ID: 5b3f0717-7478-11e7-94fc-b870f4f26fbf

...
but I can't see that there should be any problem with the path?
Then again, I am good at missing the obvious :p

(I can reinstall it, but I've previously done that without it seeming to do any difference
 
S

Sully

Guest
#13
Ooooo! Neat. I definitely have to remember that one.

my OS is in Norwegian since I try to help my parents now and then, but,
what it tells me is basically:

Wrong process ID
Wrong start time
Wrong program path
Wrong module path


...
Programnavn med feil: EMPIRES2.EXE, versjon: 0.14.22.712, tidsangivelse: 0x39660360
Modulnavn med feil: EMPIRES2.EXE, versjon: 0.14.22.712, tidsangivelse: 0x39660360
Unntakskode: 0xc0000005
Feilforskyvning: 0x0000e415
Feil prosess-ID: 0xb50
Feil starttid for program: 0x01d3088514573d13
Feil programbane: C:\Program Files (x86)\Microsoft Games\Age of Empires II\EMPIRES2.EXE
Feil modulbane: C:\Program Files (x86)\Microsoft Games\Age of Empires II\EMPIRES2.EXE
Rapport-ID: 5b3f0717-7478-11e7-94fc-b870f4f26fbf

...
but I can't see that there should be any problem with the path?
Then again, I am good at missing the obvious :p

(I can reinstall it, but I've previously done that without it seeming to do any difference
Lol .exe is all I understand in that log but you're right sounds like a reinstall of the game might fix it.
 
W

wwjd_kilden

Guest
#14
Didn't help (same error message).:(

apparently the 00.....5 error is a ram error, but a very vague one that can mean practically anything :p
 
W

wwjd_kilden

Guest
#16
4GB
It worked on my old machine (win 95) though, I doubt it had more RAM since the hardware in it was oooooooooooold
 
S

Sully

Guest
#17
4GB
It worked on my old machine (win 95) though, I doubt it had more RAM since the hardware in it was oooooooooooold
Oh, that's pretty low. Try the paging file thing. Maybe you can shutdown whatever services or apps running in the background as well. You might want to double the ram if you can that's the best answer.
 
W

wwjd_kilden

Guest
#18
Hmm. Interesting.

Game still doesn't start
... but if my laptop start behaving better now (lagging less), then I know what to do to my mother's laptop :D